OpenVINO™ツールキット AttributeError: ' Graph ' オブジェクトには属性 ' node ' がありません。

ドキュメント

エラーメッセージ

000055576

2020/07/31

メモこの問題は修正されているため、OpenVINO toolkit を最新リリースにアップデートしてください。

何が表示されていますか?

Model Optimizer version:     2019.3.0-375-g332562022
[ ERROR ]  -------------------------------------------------
[ ERROR ]  ----------------- INTERNAL ERROR ----------------
[ ERROR ]  Unexpected exception happened.
[ ERROR ]  Please contact Model Optimizer developers and forward the following information:
[ ERROR ]  'Graph' object has no attribute 'node'
[ ERROR ]  Traceback (most recent call last):
  File "/opt/intel/openvino_2019.3.334/deployment_tools/model_optimizer/mo/main.py", line 302, in main
    return driver(argv)
  File "/opt/intel/openvino_2019.3.334/deployment_tools/model_optimizer/mo/main.py", line 261, in driver
    custom_layers_mapping_path=custom_layers_mapping_path)
  File "/opt/intel/openvino_2019.3.334/deployment_tools/model_optimizer/mo/pipeline/caffe.py", line 65, in driver
    graph, original_shapes = loader.caffe_pb_to_nx(proto, model)
  File "/opt/intel/openvino_2019.3.334/deployment_tools/model_optimizer/mo/front/caffe/loader.py", line 294, in caffe_pb_to_nx
    graph.add_node(layer.name, pb=layer, model_pb=model_layer, kind='op', type='Parameter')
  File "/opt/intel/openvino_2019.3.334/deployment_tools/model_optimizer/mo/graph/graph.py", line 505, in add_node
    node.update_node()
  File "/opt/intel/openvino_2019.3.334/deployment_tools/model_optimizer/mo/graph/graph.py", line 470, in update_node
    in_ports_count = self.in_ports_count if self.has_valid('in_ports_count') else None
  File "/opt/intel/openvino_2019.3.334/deployment_tools/model_optimizer/mo/graph/graph.py", line 161, in has_valid
    return self.has(k) and not self.graph.node[self.node][k] is None
  File "/opt/intel/openvino_2019.3.334/deployment_tools/model_optimizer/mo/graph/graph.py", line 158, in has
    return k in self.graph.node[self.node]
AttributeError: 'Graph' object has no attribute 'node'

[ ERROR ]  ---------------- END OF BUG REPORT --------------
[ ERROR ]  -------------------------------------------------

 

その理由は何ですか?

モデル・オプティマイザーと Python * NetworkX パッケージ・バージョン2.4 に互換性の問題があります。

修正方法:

次のコマンドを実行して、Python * NetworkX バージョン2.3 をインストールします。

pip3 install networkx==2.3